Différences entre versions de « BoyWiki:Agora/10 novembre 2013 »

De BoyWiki
(Problème Ubuntu ?)
Ligne 18 : Ligne 18 :
 
::Je donne ma langue au chat :-/
 
::Je donne ma langue au chat :-/
 
::[[Utilisateur:Caprineus|Caprineus]] 10 novembre 2013 à 20:49 (GMT)
 
::[[Utilisateur:Caprineus|Caprineus]] 10 novembre 2013 à 20:49 (GMT)
 
+
:::Voici ce qu'indique le code CSS concernant les polices employées par le modèle :
 +
:::<code>font-family: Athena, Gentium, 'Palatino Linotype', 'Arial Unicode MS', 'Lucida Sans Unicode', FreeSans, 'DejaVu Sans', sans-serif;</code>
 +
:::Parmi celles-ci, tu disposes desquelles sous Ubuntu ? La première police de cette liste que tu possèdes semble donc 'a priori' poser problème. À moins que ça soit le navigateur sous Ubuntu qui a un problème... Faudrait essayer avec un autre navigateur n'utilisant pas le moteur de Firefox sous Ubuntu. [[Utilisateur:Lascar|Lascar]] 10 novembre 2013 à 21:12 (GMT)
 
[[Catégorie:Agora]]
 
[[Catégorie:Agora]]

Version du 10 novembre 2013 à 21:12

Agora/10 novembre 2013

Mystère grec à propos de Hyacinthe

Dans la nouvelle page Couple pédérastique mythologique, tout fonctionne bien, sauf le nom grec de Hyacinthe, lorsqu'il est inclus dans le modèle {{lang}} :

Il semble y avoir une incompatibilité graphique entre les caractères accentués et ά : employés séparément ou avec d'autres lettres, ils ne posent pas de problème, mais il est impossible de les justaposer sans que ça crée un grand espace indésirable.

A noter que le problème est identique si au lieu du code de langue grc (grec ancien) on utilise el (grec moderne). En revanche il n'existe plus en dehors du modèle {{lang}} :

Ni en dehors de BoyWiki ! Ça marche très bien sur Wikipédia (sauf que le modèle employé est grec ancien et non lang|grc) : Hyacinthe.

Caprineus 10 novembre 2013 à 13:54 (GMT)

Je ne vois quasiment aucune différence entre les 2 éléments cités. La seule différence, minime (mais je ne connais pas la langue grecque) se situe au niveau des accents, moins prononcés dans la typographie avec le modèle. En tout cas pas d'espace insécable. Bref, le problème se situe pour toi soit au niveau du navigateur (ce qui serait le moins grave), soit au niveau du système d'exploitation. Je n'ai testé qu'avec mon navigateur habituel, vu que ça marche. Lascar 10 novembre 2013 à 18:58 (GMT) 
Ah... Tu m'inquiètes, là.
Je précise donc : avec le modèle {{lang}}, les caractères grecs s'affichent en sérif, alors que sans le modèle ils sont en sans-sérif, comme le reste du texte — déjà ça fait une différence visuelle importante.
Mais le problème n'est pas là. Avec le modèle, il y a entre le et le ά de Ὑάκινθος un espace vide équivalent à environ 5 ou 6 em. C'est la première fois que je vois un tel phénomène !
J'utilise Firefox (version ESR 17.0.10 de TOR Browser) et Ubuntu 12.4.
Bon, du coup je viens d'aller voir dans mon vieux Windows XP, avec le même Firefox ESR 17.0.10 de TOR Browser : ça s'affiche parfaitement, sans espace incongru !!! Donc le problème semble bien être dans Ubuntu (et la police grecque sérif qu'il utilise).
Je donne ma langue au chat :-/
Caprineus 10 novembre 2013 à 20:49 (GMT)
Voici ce qu'indique le code CSS concernant les polices employées par le modèle :
font-family: Athena, Gentium, 'Palatino Linotype', 'Arial Unicode MS', 'Lucida Sans Unicode', FreeSans, 'DejaVu Sans', sans-serif;
Parmi celles-ci, tu disposes desquelles sous Ubuntu ? La première police de cette liste que tu possèdes semble donc 'a priori' poser problème. À moins que ça soit le navigateur sous Ubuntu qui a un problème... Faudrait essayer avec un autre navigateur n'utilisant pas le moteur de Firefox sous Ubuntu. Lascar 10 novembre 2013 à 21:12 (GMT)